2011年7月8日金曜日

python: pylint は 0.22 から python 2.4 のサポートを打ち切ってた

Changelog:

2010-11-15  --  0.22.0
    * python versions: minimal python3.x support; drop python < 2.5 support

さらに pylint だけ 0.22.0 に戻してもダメで、依存する logilab-astng と logilab-common も戻す必要があった。

結局、

  • pylint-0.21.4
  • logilab_common-0.52.1
  • logilab_astng-0.20.4

で動くようになった。

CentOS5 の標準パッケージの Python は 2.4。 ここに pylint を入れようとしてハマった..

0 件のコメント:

コメントを投稿